PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Vista x64 - Keine Thumbnails für Videos im Explorer mehr


LordDeath
2008-05-17, 20:56:34
Hallo,

mein Problem ist es, dass ich im Vista Explorer nur Vorschaubilder zu wmv und mpeg Videos sehen kann. Für avi, mp4 oder mkv Dateien geht nichts.
Ich kann mich erinnern, dass irgendeine Version von Nero 7 oder 8 bei der Installation dies verbrochen haben soll.
Allerdings habe ich keine Ahnung, wie man die Vorschaubilder wieder zum funktionieren bringen kann. Kennt ihr da was?

sei laut
2008-05-17, 21:17:38
Ob Vorschaubilder kommen, hängt davon ab, mit welchem Programm sie verknüpft sind.
Das geht für jeden Dateityp extra.
Einstellen kannst du das in den Ordneroptionen und dann der 3. Reiter. Dort die entsprechende Dateiendung (.avi etc) auswählen und das Programm auswählen, mit dem es geöffnet werden soll. Beim Windows Media Player sollten Vorschaubilder erscheinen, aber auch beim kostenlosen Media Player Classic ists so. Weißt du wohl selbst am besten, was du normal nimmst.
Edit: Bei mir ist das auch so. Komische Sache. Obwohl .wmv und .avi mit dem gleichen Programm verknüpft sind. :|

LordDeath
2008-05-17, 21:22:16
Also meine Videos werden ja alle mit dem MPC geöffnet. Davon scheint es nicht abzuhängen. :(

HeldImZelt
2008-05-17, 22:50:21
Das erledigen Shell Extensions. Ich glaube aber nicht, dass Microsoft MP4 oder MKV unterstützen würde, daher wird es eher eine 3rd Party Extension gewesen sein. Ich könnte mir vorstellen, dass es der Haali Media Splitter gewesen ist. Achte im Setup auf 'Shell Extensions' und installier diese.

Abgesehen davon ist die windowseigene Videovorschau-Extension immer die Erste, die ich (in XP) abschalte, weil sie nicht fehlerfrei ist. Beispiel: Avi Datei löschen. Während die zu löschende Datei angeklickt wird, greift die Shell Extension auf genau jene Datei zu, um Metadaten und Vorschaubild zu erstellen. Kurioserweise lässt die Shell Extension die Datei dann manchmal nicht wieder los und der berühmte Spruch erscheint: "Die Datei wird von einem anderen Prozess benutzt und kann nicht gelöscht werden". Abhilfe schafft nur ein abschießen des Hostprozesses (explorer.exe) oder ein Neustart des Systems. Präventives abschalten und deaktivieren der Vorschaufunktion geht mit: regsvr32 /u shmedia.dll

Das ist für XP. Vista weiß ich nicht mehr, schon zu lange her...

Maniac
2008-05-18, 13:14:26
Das Problem dürfte daher kommen, dass der Explorer zum Erstellen der Vorschaubilder nur auf 64bit-Codecs zugreifen kann. Aus gleichem Grund ist in Vista 64 wohl auch der WMP als 32bit-Version Standard und nicht der WMP in 64bit, eben weil es die meisten Codecs momentan leider nur als 32bit-Version gibt.

Lösung des Problems ist, die Codecs (auch) in einer 64bit-Version zu installieren. ffdshow gibt es beispielsweise als 64bit-Builds. Damit funktionieren die Vorschauansichten im Explorer und man kann außerdem den Standard-WMP von 32 auf 64bit switchen (falls man denn den WMP verwendet).

Gast
2008-05-18, 13:15:45
das problem sind fehlende splitter/decoder.

um ein bild generieren zu können braucht es natürlich diese um überhaupt an die bilddaten zu kommen.

der windows-explorer ist in der x64-version ein 64bit-programm. das bedeutet, dass dieser nur mit 64bit-dlls, also auch nur mit 64bit-decoder linken kann.

die meisten decoder und splitter sind aber 32bit-programme und können deshalb auch nur von 32bit-playern verwendet werden.

du müsstest für die gewünschten dateien also noch 64bitige decoder/splitter installieren, damit ein 64bit-player (und der explorer ist nichts anderes) diese auch anzeigen kann.

LordDeath
2008-05-18, 13:42:25
Ihr habt Recht! :)
Ich habe einfach ffdshow_rev1943_20080416_clsid_x64.exe installiert und schon zeigen avi Dateien eine Vorschau. Danke!